Synology usage series 17: Install WebDav with Lighttpd


Mouting a webdav folder with Windows XP

  1. Open file explorer
  2. Tools > Map Network Drive

    explorer_map_network_drive_1

  3. Click ‘Sign up for online storage or connect to a network server.’
    explorer_map_network_drive_2
  4. Click Next button.
  5. Select ‘Choose another network location. Specify the address of a Web site, network location, or FTP site.’
    Windows XP - Map Network Drive - Choose another network location

    Windows XP - Map Network Drive - Choose another network location

  6. Click Next button again
  7. Input https://<your DS IP address>:<https port of the lighttpd, i.e. 91>/, click next again.

    Windows XP - Map Network Drive - Mapping a Secure WebDav Directory

    Windows XP - Map Network Drive - Mapping a Secure WebDav Directory

  8. Keep clicking ‘Yes’ for all security alerts

    explorer_map_network_drive_5

  9. You will be prompted for user name and password.
    Windows XP - Map Network Drive - Input username and password

    Windows XP - Map Network Drive - Input username and password

  10. Input the name of the share

    explorer_map_network_drive_7

  11. Click next again
  12. Finally click finish button

    Windows XP - Map Network Drive - Click 'Finish' to create a new network drive

    Windows XP - Map Network Drive - Click 'Finish' to create a new network drive

Your folder will now be mounted and the connection will be encrypted with https 🙂

References





9 thoughts


  1. Thanks for the guide, trying to install on my CS 407

    All well until I try to run lighttpd

    Using 80,91,443 ports i get the following message

    (network.c.296) can’t bind to port: 192.0.168.199 443 cannot assign requested address

    HELP!!

    Probably doing something really silly but your help would be greatly appreciated

    BW

    PF

  2. hello.

    It looks like the ports were being used by some other services. You can verify this using the command below

    # netstat -a

    This command allow you to know what services are currently listening to what port in your diskstation.

    You can try other port which is not listed in the result above.

    Hope this help

    P.S. If you dunno how to read the result, you can capture it and send to me using the contact me form.

  3. Thanks for your tutorial! It seems really useful!

    I’m on a DS209+II with the newest firmware.

    I tried to do step 6:
    “/volume1/opt/etc/init.d/S80lighttpd start”

    but on my machine “opt” is called “@optware” so I ran:

    “/volume1/@optware/etc/init.d/S80lighttpd start”

    instead. unfortunately I got an error:

    Host> /volume1/@optware/etc/init.d/S80lighttpd start
    Starting web server: lighttpd
    Duplicate config variable in conditional 0 global: server.port
    2010-02-17 12:19:50: (configfile.c.907) source: /opt/etc/lighttpd/lighttpd.conf line: 151 pos: 16 parser failed somehow near here: (EOL)

    Any ideas? it would be great to get WebDAV working.

  4. Hi,

    Trying to install webdav on a DS-109j. But when creating the ssl certificate I get the following error: Illegal instruction (core dumped). I also get this error when trying to start lighttpd.

    What could be wrong? Any help would be very nice!

  5. Done everything ok, only when starting up lighttpd I get this error (on DS 209):

    Starting web server: lighttpd
    2010-03-14 01:59:50: (network.c.529) SSL: error:00000000:lib(0):func(0):reason(0)

    Any help appreciated.

    • I don’t have a DS209 so I couldn’t help much. I googled a bit and thinks it is related to some known bugs of lighttpd.

      You should have better luck submit your question in synology official forum.

Leave a Reply

Your email address will not be published. Required fields are marked *